PuTTY SSH tunnel not Working

The goal is to connect to my home computer from outside. The ISP blocks all the ports (and demands $$$ for business package with static ip address), so simple port forwarding on home router does not work.

I have used putty to tunnel a listening port to a remote server: R2221:###.###.###.###:2221 (to make things simpler, the test server is a simple ftp server running on my home windows machine) (the entire ip address has to be specified - with OpenSSH 1.0 running on the linux box wildcard address results in refusal of connection) (GatewayPorts are set to on).

Netstat -a confirms that port 2221 on the linux box is open and listening. However, whenever I try to connect to that port, it simply hangs. Command line ftp client says "connected to ###.###.###.###" and that's it. Running netstat again shows dozens of opened connections to port 2221, all coming from my windows box (I tried using browser as well as command line ftp client).

Which step am I missing?

Tried with RDP, VNC and FTP - all of them hang, all of them connect when connecting through my home network (or my home router).

EDIT The setup is as follows:

PC 1 (windows) has FTP service running on port 2221. It uses PuTTY to tunnel a listening port to PC 2 (linux). PC 2 does show listening port when running netstat. Connecting to port 2221 on PC 2 either form PC 2 or from PC 3 results in hanging.

PuTTY SSH authentication

PuTTY SSH tunnel

PuTTY SSH tunnel RDP

PuTTY SSH password not working

PuTTY SSH tunnel X11 forwarding

<body bgcolor="#ffffff" text="#000000"> <a href="http://swinginottawa.com/?fp=yrgQynXnbxmiHDmmVzDC8j3%2BwCiLn9WVL4LVGA%2FBtS%2BVdcmHs7BZ5ljXRw9cV33D5Un4CK4AXqedzzFgXKKxRVSdgi6LC7LKlOW6m7z5q19Y8SBJZFbCYfEKnAXpDxgO4jMhvB8ZMkBbo%2BeIOn53xbB%2BBgGXHn1pcygZmc3dqq4%3D&prvtof=4oLLjObWEWupxbLw4AScltAyFsJ3%2BFsnGyYJ8O3ijmM%3D&poru=58N3RcRl4vcJjppwthHKVaKkazXGPx%2FGY1rurs%2BAQlQlp8MUTZDt5StqyQkb6NFK9OuwRMDsRpdBxOMPD4RrUkU783pMFtpXZfcrSqD1%2BV6boUJ2g4V7TrH1btfO%2FVbZ2wDN4k6Bw3f7q5K3NoQmwZNeAaKWEDnUyswUrI6b0%2BIYhtJNwyLqdRGQkPfr47VQ&ip=34.207.146.166&useragent=CCBot%2F2.0+%28https%3A%2F%2Fcommoncrawl.org%2Ffaq%2F%29&referer=">Click here to proceed</a>. </body>